修復ERR_SSL_PROTOCOL_ERROR在簡單的步驟中

經過 Yvonne
2022-11-03

您必須至少看到一次ERR_SSL_PROTOCOL_ERROR警告或"這個網站可以't提供安全的連接"問題如果Google Chrome是您互聯網的窗口。關於此錯誤的煩人部分—或一組錯誤,真的—這是經常沒有明顯的原因。最受歡迎和最受歡迎的網站都容易受到SSL問題的影響。哎呀,我'VE已經在我們的網站上已經有一個,我可以向您保證我們的SSL/TLS設置足夠了。

Solutions to ERR_SSL_PROTOCOL_ERROR Chrome

它'幾乎不可能指出一個谷歌偶爾報告的單一原因"這個網站可以't提供安全的連接,"正如我們剛剛解釋的那樣。從錯誤的系統日期到更複雜的服務器問題,這幾乎可能是任何事情。

暫時,讓'S將診斷組件放在一邊,專注於治療,這就是為什麼您在這裡。

這是Google Chrome的簡短故障排除指南's err_ssl_protocol_error。如果第一個嘗試,請嘗試下一個'工作。您最終應該能夠解決此問題。

This site can’t provide a secure connection

設置適當的日期和時間來解決ERR_SSL_PROTOCOL_ERROR

看起來很簡單,不是't?在大多數情況下,問題的最簡單答案是正確的答案。在這種情況下,它'錯誤的日期和時間設置可能會導致您問題。因此,檢查您的系統是否為't在計劃後面或提前運行。

為什麼這很重要?仔細跟踪證書的簽署日期,並且其到期日期是必要的,因為證書有效性是身份驗證過程的關鍵組成部分。如果您的系統存在問題,身份驗證問題可能會以多種方式出現'時間和日期。因為這些瀏覽器是謹慎的,所以像錯誤的時間一樣簡單的事情可能會導致SSL連接問題。

修復err_ssl_protocol_error通過清除chrome'S瀏覽歷史

它'S擦除鉻的時間'S緩存和cookie如果您已經有正確的日期和時間。為此,請按CTRL + Shift + Delete刪除您的Internet歷史記錄。即使這沒有't解決"這個網站可以't提供安全的連接"問題,我們建議定期刪除您的瀏覽歷史記錄。

清除您的SSL狀態以解決ERR_SSL_PROTOCOL_ERROR

清除您的SSL狀態是下一件事,如果上面的兩種方法't幫助。為此,請遵守以下程序:

  • 首先,單擊您可以在X(關閉)按鈕下方看到的三個點,以訪問自定義和控制Google Chrome。
  • 立即單擊設置。
  • 通過將光標向下移動到頁面上,打開高級設置。
  • 在搜索欄中搜索或向下滾動以找到打開的代理設置。
  • 這'互聯網屬性'窗口將出現。
  • 單擊“內容”窗口中的“清除SSL狀態”按鈕。

通過關閉QUIC協議,您可以修復ERR_SSL_PROTOCOL_ERROR

與Google的TLS/SSL等效連接'S服務器可通過QUIC(快速UDP Internet連接)提供。 Chrome默認情況下已經啟用了QUIC協議。複製Chrome:/flags/#啟用Quic並將其粘貼到URL欄中,然後按Enter將其關閉。實驗QUIC協議將被設置為屏幕頂部的默認設置。將其關閉,然後重新開始Chrome。

雖然我們不願意'總是推薦它,已經證明在某些不同尋常的情況下起作用,所以我們'將其包括在列表中。

檢查您的防病毒設置以解決ERR_SSL_PROTOCOL_ERROR

由於某些網站仍然採用的較舊,較不安全的SSL/TLS協議,此步驟並不完全安全。

您可能不知道這一點,但是您的防病毒軟件監視您訪問的網站,並捍衛您免受可能包含或擺姿勢的任何危害。它通過檢查網站來實現這一目標'SSL/TLS協議的使用。您被阻止訪問站點,因為它認為該協議是有風險和過時的。

隨著UI和設置因軟件而異,沒有't一種修改所有防病毒程序設置的一種方法。確定是否正在通過找到SSL協議來搜索SSL協議。如果確實如此,請將其關閉並觀察結果。如果問題仍然存在,請將所有內容重置為默認設置。

通常,當SSL/TLS連接通過防病毒工具標記時,'s由於服務器正在嘗試使用過時或脆弱的SSL或TLS版本建立連接,因此SSL 3.0或TLS 1.0。大學教師't更改您的防病毒軟件或降低TLS版本設置以容納網站'S SubPar SSL/TLS配置,作為我們'在過去的文章中建議。風險遠大於收益。

啟用所有SSL/TLS版本以解決ERR_SSL_PROTOCOL_ERROR

由於某些網站仍然採用的較舊,較不安全的SSL/TLS協議,此步驟並不完全安全。

訪問SSL/TLS協議時,啟用了SSL的網站與服務器進行通信。您的Chrome版本有時可能與網站不兼容'S SSL/TLS版本以來't允許默認情況下使用不建議的SSL/TLS協議。因此,需要更改SSL/TLS協議設置。這是如何解決的方法:

  • 在Chrome中,通過單擊瀏覽器右上角的三個點來選擇設置。
  • 現在通過向下滾動導航到高級設置。
  • 找到並打開代理設置。
  • 選擇"先進的"
  • 在出現安全部分之前,向下滾動。現在,您使用了所有可用的SSL和TLS版本。
  • 點擊應用。
  • 再次啟動Chrome。

同樣,這個建議純粹是假設的。所有主要瀏覽器都計劃在TLS 1.2之前停止支持所有TLS版本,包括最近發布的TLS 1.3。安全考慮是背後的原因。禁用對已知安全缺陷的過時的TLS和SSL版本的支持。沒有值得信賴的公司會要求您更改瀏覽器'S安全設置以訪問其網站。